Είναι ούτως ή άλλως εκεί για να εγκαταστήσετε δυο μονάδα σε Python 3

ψήφοι
1

Θέλω να εγκαταστήσετε την ενότητα Python TWAIN σε Python 3. Αλλά τα έγγραφα που λέει:

Οι εκδόσεις Python 2.1 μέσω 2.5 υποστηρίζεται.

Μπορώ να το μετατρέψετε τη χρήση 2to3;

Δημοσιεύθηκε 12/01/2016 στις 13:06
χρήστη
Σε άλλες γλώσσες...                            


1 απαντήσεις

ψήφοι
0

Χρησιμοποιήστε τελευταία μονάδα που παρέχει μια πειραματική πακέτο μετάφρασης για να σας βοηθήσει με την εισαγωγή και χρήση παλαιών μονάδων Python 2 σε ένα περιβάλλον Python 3.

Έτσι, εγκαταστήστε το πακέτο σας με pip

pip3 install twain --no-compile   # to ignore SyntaxErrors

Και χρησιμοποιούν επόμενο κωδικό για την εισαγωγή δυο που σου python3κωδικό:

from past import autotranslate
autotranslate(['twain'])

import twain


# use twain ....... 
Απαντήθηκε 12/01/2016 στις 13:13
πηγή χρήστη

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more